
Drawing practices in Pro/Engineer 
 
The drawing must contain complete and unambiguous information about 

o the part geometry and size,  
o information on part material,  
o surface finish,  
o manufacturing notes,  

and so on.  
 

Over the years, the layout and practices used in engineering drawings have become standardized which makes it easier for 
anyone to read the drawing, once they know what the standards are.  
 
Fortunately, Pro/E makes creating drawings relatively easy. All the standard practices are basically built-in. However a 
number of commands are necessary to improve the “cosmetics” of the drawing. 
 
Doing drawings with Pro/E lets you concentrate on what to show in the drawing instead of spending time searching for how 
to show it.  
 
The Pro/E solid model contains all necessary and sufficient information in order to define the part geometry. Therefore, by 
getting all this information into the drawing, it is very difficult to create a drawing with inaccurate information. 
 
You have already taken the tutorial on the Pro/E WildFire, including the production of a drawing with default template.  
 
In this lesson, we are going to create a drawing without template. This will help you to learn additional features of Pro/E. 
This is a tutorial, with the difference that you don’t have access to the computers now. However, this lecture note will be 
available for downloading and independent training. 
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Here is the plan of our lecture: 
 
► Creating the part 

• changing part units 
► Creating the drawing 

• selecting the sheet 
• creating the views 
• adding dimensions 
• cosmetic changes 
• adding a note 

 
► Changing the part/drawing - exploring associativity 
► Using a drawing template 
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Creating the Part 
 
You are supposed to know already how to do it. Just couple important things will be emphasized here. 
 
First, we'll create the part shown in Figure  below.  
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Open the new file, call this part lbrack and use the default template for a solid part.  
 

 
 
When you create the part, make sure that the back surface of the vertical leg is aligned with FRONT, the lower surface of the 
horizontal leg is aligned with TOP, and the vertical plane of symmetry is RIGHT.  
 
 
 

 4



Note that in a standard Pro/E installation, the default template contains units of inches.
However, we can use not only imperial system but any other set of units. 
Here's how to change the part units. Select (from the pull-down menu) 
 
Edit > Setup > Units  
 
The Units Manager window opens, as shown:  
 

i 
 
This lists the common unit systems in Pro/E. The current units are indicated by the arrow pointer.  
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Select the line containing the unit system 
 
millimeter Newton Second 
 
and then Set. A warning dialog opens.  
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When you change the units of a model, you have two options that will affect all linear dimensions: 
 

Convert dimensions - This leaves the model the same real size as the original. For example, a 
10 inch long bar will be converted to a 254mm long bar. The dimension number changes.  
 
Interpret dimensions - This keeps the dimension numbers the same, but interprets them in the new units. In our example, the 
10 inch long bar becomes a 10mm long bar. 
 

 Managing units is especially important in producing assembly of parts. Make sure that the units in all components are 
identical! 

 
 It is critical to be aware of units, when working in a design group. Some people may be working in inches while others – 

in millimeters.  
 

 3D models downloaded from the web also come in all varieties.  
 

The classic blunder that has occurred due  to mix-ups in the interpretation of units or people making assumptions about 
units used by others, is the loss of the Mars Climate Orbiter in 1999 ($125M US). The specialists from NASA and  
 Lockheed Martin Corp. have been involved. The spacecraft's builders from Lockheed specified the thrust in pounds, 
and NASA scientists thought it was a metric measurement. The Orbiter was off course by 100 km and disappeared in space! 

 
Changing units is very easy in Pro/E in any stage of solid modeling or assembling. It is a really strong feature of the s/w, 
comparing with other packages. 
 
If you have used the dimension values in the figure above, then you want to pick the second option here (Interpret dimensions) 
and select OK. Close the Units Manager window. When this is applied, double-click on the protrusion to verify that the 
dimension numbers haven't changed. 
 
Don't forget to save the part! We are now ready to create the drawing.  
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Creating the Drawing of the L-Bracket  
 

1. Create the Drawing Sheet  
 
Select the following: 
 

File > New > Drawing | [Ibrack] 
 

 
 
Deselect the option Use default template. Select OK. 
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The New Drawing menu will open up:  
 

 
 
Note the currently active part is automatically selected as the drawing model.  
 
Keep the defaults for the template (Empty) and orientation (Landscape),  
but change the Standard Size option to A (8-1/2" by 11" in landscape mode).  
 
OK 
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A new window will open up with the title LBRACK (Active) 
 
This will overlap or cover the part window, which is still 
open but pushed to the back. 
 
 
 
 
 
 
 
 
 
 
 
 
You can switch back and forth between the part and drawing 
windows using Window (in the pull-down menu).  
 
 
Current windows are listed at the bottom of the menu. If 
several windows are in view, only one of them will be active 
at a time (indicated by the word Active in the title). 
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Quite a few things have changed in the user interface.  
 

 Some new toolbar buttons have been added at the top 
and on the right.  

 
The top toolbar contains most of the basic commands for 
creating and managing drawings.  
 
Despite the appearance of so many commands, creating 
entities will not be a significant amount of work in Pro/E 
– almost all of the drawing will be done for you 
automatically.  
 

 The toolbar on the right contains drawing commands 
(as in Sketch mode: creating lines, arcs, etc.).  
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2. Adding Views 
 

In the pull-down menu, select  
 
Insert > Drawing View> General (or use the top toolbar button Add View) 
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The view we will place first will be our primary view.  
It will be the front view of the part, so select a center point a bit left and below the center of the sheet, as shown. 
 The Drawing View dialog window also opens. 
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The Drawing View window contains all the options for creating (and changing properties) of views on the drawing sheet.  
This includes  

• view type and orientation,  
• section views,  
• edge display,  
• scale, etc. 

  
Select the View Type category. We want to set the desired orientation of the primary view. This will be the front view of the 
bracket. In the Model view names list, select FRONT from the list of views defined in the  model.  

 
Now select Apply at the lower right, then Close. 
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The view has a dashed red box around it. This means that it is the currently selected view. Click anywhere else on the sheet to 
turn off the selection highlight. Turn off the datum display (if you have it on) and Redraw. Your drawing should look like this 
 

 
 
The right and top views could be created using the Add View button and again selecting the General view and the RIGHT and 
TOP named views in the View Type lists.  
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Adding top view: 
 

 
 
 

Added top view: 
 

 

Adding right view: 
 

 
 
 

Added right view: 
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However, this will not automatically align these new views with the primary view. The views can be easily moved with respect 
to each other: 
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One way to align them is manual alignment: 
 
 

 
 
 
 
 

For this you have to select the option Alignment and then to 
indicate the type of alignment and the views to be aligned. 
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Another way – to create projected views off the primary. 
 
Select the primary view so that it is highlighted with the red box. Now select Insert Projection View.  
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You will now see a sliding border that will always align with the parent view.  
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Position the mouse somewhere to the right of the primary view and click – the right side view appears.  
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To create the top view, we once again select the primary view (this is what we want to project from) and command Insert 
Projection View. Click above the front view to get the top view.  
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If you don't like the spacing of your views, you can easily move them. By default, views are locked in place where you created 
them. In order to move a view, this lock must be turned off. You can do this in any of three ways: 
 
 

• turn off the Lock View button in the top toolbar  
or  

• select Tools > Environment in the menu, and turn off Lock View Movement 
 or 

• select a view, then in the Right Mouse Button (RMB) pop-up, turn off Lock View Movement 
 
When you move views, Pro/E will ensure that your 
projected views stay aligned. Select the right side view - it 
will be surrounded by a red border and have a drag handle 
at the center.  
 
 
Use the drag handle to move the view. Try to move the 
view up, down, left, and right on the screen (you can't 
move up or down since the view must align with the front 
view since it is a projection). 
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Left-click again to drop the view at the new location.  
 

 
 
Try moving the top view.  
 
Finally, try moving the front view. You should see the 
other views move to maintain the correct orthographic 
alignment: 
 
 
 
 

 
 

 
 

Click the left-mouse button on an open area of the screen 
(i.e. not on another view) when you are finished moving the 
views to rum off view selection.  
 
Turn the view lock back on. 
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Let's add a fourth view that shows the part in 3D.  
 
Note that this is not a projected view but a general one.  
 
We'll scale this one down to half size too. In the RMB 
pop-up menu or in the main menu, select 
 
Insert General View 
 
then click in the top right comer of the sheet. The view will 
appear. In the Drawing View window, under the View Type 
category, select the Default Orientation, then Apply. 
 
 
 

 

 
Select the category Scale:  
 
Make sure that the Custom Scale is 0.5 and once again select 
Apply > Close. 
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Finally, the drawing should now look like: 
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3. Adding Dimensioning Detail 
 

In the pull-down menu select  
  
View > Show and Erase 

 
(or select the Show/Erase button) 

 
 
 

A new window opens with a number of detailing types and 
options as shown in Figure.  
 
Select 
 
Dimension (the top left button) 
Show By (Part) 
Preview > With Preview (should be checked) 
Show All 
 
Because we selected Show AII  (which is a potentially 
hazardous thing to do since a part or assembly might have 
hundreds of dimensions!), confirmation will be requested 
(select Yes).  
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All of the part dimensions used to create the model will be put up on the display in pale yellow (or white). 
 

 
 
We can:  

• erase them all,  
• keep them all, or  
• just select the individual ones 

we want to keep or remove.  

 
There aren't too many dimensions in this drawing so select. Press  Accept Alt > Close in the Show/Erase window. Click 
anywhere on the drawing. The dimensions will change to yellow. 
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The dimensions put on the drawing using Show/Erase are exactly the ones you used in your sketches to create the features.  
 
These are called Shown dimensions.  
 
This lesson is to use the dimensions in feature creation that you want to appear on the drawing.  
 
You already know something about drawing standards and how you want the dimensions laid out in the drawing, and this is 
important to know before you start to create the solid model - a point often missed by many.  
 
The purpose of this lecture is to give you an introduction to the placement of the Shown dimensions. 
 
 
 
Another type of dimension can be created in the drawing, naturally called Created dimensions. 
 
This type of dimensioning you will have to learn on your own – from the textbooks or from the on-line help. 
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4. Dimension Cosmetics 
 

Although all the dimensions are now on 
the drawing, we may need to improve their 
placement and appearance.  
 
For example, some of the dimensions may 
be a little bit crowded.  
 
To fix this, select the following  
 
Edit > Cleanup > Dimensions 
 
 
(or use the Cleanup button) 
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This opens this window   

 
 
We have to identify which dimensions we want cleaned. 
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Holding down the LMB, draw a selection box around the entire drawing, then select OK. The number of dimensions affected 
will appear at the top of the Clean Dimensions window.  
 

 
 
Accept the default distances for the offsets (the 0.5 is the spacing in inches from the edge of the part to the first dimension line, 
the 0.375 is the offset between parallel dimension lines). Pick on the Apply button. All the dimensions should spread out and 
appear in dark red.  
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Depending on your view placement and dimensioning scheme (for example, too little room between views) you may have error 
messages and warnings in the message window. Close the Clean Dimensions window. All dimensions should now be in yellow. 
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There is a lot more we can do to modify the display esthetics of the dimensioning detail. 
 
Some of the dimension placement locations chosen by Pro/E may need to be touched up a little:  

- to switch some of the dimensions to a different view,  
- to modify spacing and location of dimensions on views,  
- to change direction of dimension arrows, and so on.  
 

For example, the location dimensions for all the holes should be on the view that shows the circular shape of the hole.  
In our case, for the two small holes, this is the front view. For the large hole, this is the top view.  
 
Most of these cosmetic modifications can be made using the mouse buttons. 
 
Pick (left click) on one of the dimensions you want to modify.  
 

 

 34



 
You will see the small square "handles" on the dimension components. Left-click on any handle in order to drag it to the 
desired position. If you select the handle directly under the dimension value, you can move it practically anywhere. The 
extension lines and arrows will automatically follow. 
 
While dragging this around, if you want to flip the dimension arrows (i.e. put them inside/outside the extension lines), just 
Right-click.  
 
When the dimension is where you want it, left-click to drop.  
 
You can continue to left-click on the handles to move the dimension, extension lines, dimension line, and arrows until you get 
exactly the appearance you want.  
 
To accept the final placement and format, click the left mouse button somewhere else on the screen or select another 
detail item.  
 
The modified dimension will turn yellow. 
 
To modify more dimensions, continue the sequence: 
 
► left-click on a dimension, 
► drag on the handles as desired using left-mouse, 
► right-click to flip arrows if desired, 
► left-click to accept 
 
until you are satisfied with the layout.  
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If you want to move a dimension to another view, after you have picked out the dimension,  
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hold down the right mouse button and select Move Item to View from the pop-up menu,  
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then left-click on the desired new view.  
 

 
 
You can also use (in the pulldown menu) Edit > Move Item to View. 
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Also available in the pop-up menu are a number of other cosmetic modification commands.  
 
The major ones are fairly self-explanatory, however one is mentioned here because of an important concept you need to know 
(you can consult the on-line help for details about the others): 
 
Erase 

 
 
This command removes detail items from the drawing. Note that this is not the same as Delete. With erase, the dimension still 
stays with the model, it just isn't displayed. It makes sense that a shown dimension that is part of the model cannot be 
deleted. However, you can create dimensions that can be deleted, since they are not necessary parts of the model. 
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5. Setting View Display Mode 
 

By default the view display of the drawing (hidden line, wireframe, etc) is determined by the view display of the part in the 
model window.  
However, shaded images cannot be used in a drawing. But it is possible that your drawing is displaying all edges as solid lines 
(hidden line and visible lines the same). This is the big mistake!  
To make sure hidden lines are treated correctly, select all four views (using the CTRL key), then in the RMB pop-up menu, 
select Properties. (You can also do this one view at a time by double clicking on it.)  
 

 

 
In the Drawing View window (you are 
automatically in the View Disp category panel 
since you selected multiple views) set the 
following 
 

Display Style (Hidden) 
 

Tangent edges (None) 
 
 
then press Apply > Close.  
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Hidden lines became grey. These view display settings are now fixed properties of the views and not affected by the top 
toolbar buttons. 
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6. Creating a Note 
 

Let's add a short note on the drawing. To fit it you may have to move the other views up a bit. You can do that after the note is 
created, if necessary.  
Select in the pull-down menu (or use the Create Note button)  
 
Insert > Note 
No Leader | Enter | Horizontal | Standard | Default | Make Note 
 
Select a location a little below the  right side view.  
 
 
A small Text Symbol window opens from which you can 
select special characters to insert in the note.  
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A note text is being typed in another special window.  
 

 
 
Pressing the enter key will advance you to 
the next line of text in the note. Pressing 
the enter key on a blank line will complete 
the note.  
 
Here the note is: 
 
ALL DIMENSIONS IN mm 
Drawn by Art O'Graphic  
21 May 2004 
 
Select Done/Return.  

 
 

If you left click on the note, you can move it around by dragging. If it is selected, you can pick the Properties command in the 
RMB pop-up. This lets you change the text and text font, and even load text from an external file or create a hyperlink. 
 
Now we can save the drawing using the default filename; Pro/E will automatically append a drw extension to the file name. 
 
File > Save 
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Exploring Associativity 
 
One of the most powerful features of Pro/E is its ability to connect the part model and the drawing. To really see the power of this 
feature, resize the drawing and part windows so that both are visible. Make sure the DRAWING window is active.  
 
Select the diameter dimension of the large hole. In the RMB pop-up menu, select Modify Nominal Value.  
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Enter a new value of 30. Click somewhere off the dimension and it will show in green.  
 

 
 
Similarly, select the height dimension and change it from 60 to 80. Now, in the top pull-down menu, select 
 
Edit > Regenerate > Model 
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The drawing should change to show the new geometry. And the part window also shows the new geometry.  
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Activate the part window, then double click on the protrusion and change the width of the bracket from 60 to 80,  
 

 
 
then Regenerate.  
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Change back to the drawing window and activate it - it shows the new shape too. 
 

 
 
 These actions show that there is a bidirectional link between the drawing and the part. If changes are made to any item, the 
other is automatically updated. The same holds true when you deal with assemblies of parts, and drawings of those assemblies. 
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Using Drawing Templates 
 
For our first drawing, we did a number of operations manually. Many of these are common to all part drawings. Fortunately, 
there is a way to do much of this tedious drawing creation automatically. 
 
First, make sure the current drawing has been saved, then remove it with File > Erase > Current. 
Note that this does not delete the drawing from your hard disk but just removes it from the current session (out of memory).  
You should be back in the part window. 
 
Create a new drawing called Ibrack2.  

 
Once again, deselect the option beside Use default template (we want to pick our own) and select OK.  
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In the New Drawing dialog window, check the button beside Use template and select an A sized drawing by picking 
a_drawing in the Template area.  
 

 
This does the following: 

• creates the drawing sheet (A size) 
• orients the model 
• places the standard views (top, front, right) for a multiview drawing 
• scales the views to give you room for detailing 
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When you select OK and enter the drawing window, everything should be set up for you as shown: 
 

 
 
The views that are shown on the drawing are determined by the layout of the template.  
The drawing template refers to standard views embedded in the part (that were likely created with the part template).  
The drawing views are based on the default datum planes TOP, FRONT, and RIGHT and the associated Saved Views.  
The orientation of the part in the drawing is therefore determined by how we orient the geometry of the part relative to the 
datums.  
If your part is upside down in the model, then the drawing views will be upside down too.  
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However, for some reason you may want to have the orientation of the part different in the model than in the drawing.  
Then if you still want to use the part and drawing templates, you can reorient the drawing views created automatically. 
Double-click on the front (primary) view. In the Drawing View window, select Category (View Type). In the view orientation 
area, select the view LEFT, then the Apply button. A confirmation window will ask if you want to modify the orientation of the 
children views (these are projections of the primary view).  
 

 
 
Select Yes.  
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All three views will change, maintaining the specified orthographic projection relation between views.  
 

 
Change the primary view back to our original FRONT view. 
 
With the views created, go ahead and finish detailing the drawing for practice. Try to do this on your own, but refer back to our 
previous procedures if necessary. 
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